OSPF Default Route on Juniper

Juniper, OSPF, Topology, rjlogs, GNS3, Junos

Continue the previous post “Configure OSPF on Juniper” , now we will configure the default route.

The scenario is IP loopback interface of J1 (1.1.1.1/32) will not advertised through OSPF, but J2 and J3 will reach it through the default route that injected into OSPF.

First of all, remove the loopback interface of J1 from OSPF :

[edit]
root@J1# edit protocols ospf area 0

[edit protocols ospf area 0.0.0.0]
root@J1# delete interface lo0.0

Continue reading “OSPF Default Route on Juniper”

Advertisements

OSPF Default Route

topology, ospf, rjlogs, gns3

With this simple topology of 2 Cisco routers, we will configure default route in OSPF.

The scenario is interface loopback 0 on R1 (100.100.100.1) will not advertised into OSPF, R2 will reach it through the default route.

First of all, we will configure on R2 :

R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut

R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut

R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.3 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0

Now move to R1, we don’t advertise loopback 0 (100.100.100.1) into OSPF because we want to reach it by default route from R2 :

Continue reading “OSPF Default Route”