OSPF Virtual Link

In OSPF Multi Area, all area must be connected to the backbone area (area 0), in order to communicate each other. Inter area routing will through the backbone area (area 0). If there’s area that isn’t connected to the backbone area we can setup a virtual link.

OSPF, Virtual Link, Cisco, Routing Protocol, GNS3

Based on topology above, area 2 doesn’t have connection/route to other area, since it’s not connected to the backbone area (area 0).

In this case, we can setup a Virtual Link from R4 to R2 and vice versa, from R2 to R4.

Continue reading “OSPF Virtual Link”

OSPF Default Route

topology, ospf, rjlogs, gns3

With this simple topology of 2 Cisco routers, we will configure default route in OSPF.

The scenario is interface loopback 0 on R1 (100.100.100.1) will not advertised into OSPF, R2 will reach it through the default route.

First of all, we will configure on R2 :

R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut

R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut

R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.3 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0

Now move to R1, we don’t advertise loopback 0 (100.100.100.1) into OSPF because we want to reach it by default route from R2 :

Continue reading “OSPF Default Route”

Configure RIP on Juniper and Cisco Routers

In this simple lab will show how to configure RIP routing protocol on Juniper and Cisco routers.

rjlogs, lab, RIP, cisco, juniper, gns3

R1 is a Cisco router, J1 and J2 are Juniper routers.

Let’s starting from J1 :

Assign IP address to each interfaces: IP 172.28.1.3/24 on interface  ge-0/0/0 that connected to R1, 172.28.2.3/24 on interface ge-0/0/1, and 1.1.1.1/32 for IP loopback interface.

[edit]
root@J1# set interfaces ge-0/0/0 unit 0 family inet address 172.28.1.3/24

[edit]
root@J1# set interfaces ge-0/0/1 unit 0 family inet address 172.28.2.3/24

[edit]
root@J1# set interfaces lo0 unit 0 family inet address 1.1.1.1/32

Now tell the router what interfaces will participate in RIP, and we have to give the process an identifier, here we call it RIP-LAB.

[edit]
root@J1# edit protocols rip

[edit protocols rip]
root@J1# set group RIP-LAB neighbor ge-0/0/0.0

[edit protocols rip]
root@J1# set group RIP-LAB neighbor ge-0/0/1.0

Continue reading “Configure RIP on Juniper and Cisco Routers”