OSPF Default Route

topology, ospf, rjlogs, gns3

With this simple topology of 2 Cisco routers, we will configure default route in OSPF.

The scenario is interface loopback 0 on R1 (100.100.100.1) will not advertised into OSPF, R2 will reach it through the default route.

First of all, we will configure on R2 :

R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut

R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut

R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.3 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0

Now move to R1, we don’t advertise loopback 0 (100.100.100.1) into OSPF because we want to reach it by default route from R2 :

Continue reading “OSPF Default Route”

Don’t Panic

This is an old story, perhaps a year ago, when I was working at one of telecommunication vendor. And I thank God, I got a lot of lessons and experiences while working there.

One day, my friend from NOC told me that the network couldn’t monitored from Cacti last night, but there was no traffic down. He asked me to check  what happened.

Well, I was thinking that it was NMS problem. I started to check the alarm log on IPRAN core device.

An alarm 400136 ID 180933 level 5 occurred at 04:40:23 04-26-2016, cleared at 05

:54:05 04-26-2016 sent by xxx_9K8E_xxx_1461 PFU-0/1/0

%PORT% Physical interface status  The physical interface xlgei-0/1/1/1 turned in

to DOWN

From the log I got notice that port xlgei-0/1/1/1 was down before, I found that this port is main link to IPBB PE router. So definitely the traffic passed through the backup link.

But wait, why no traffic shown by Cacti server?

Continue reading “Don’t Panic”

Configure RIP on Juniper and Cisco Routers

In this simple lab will show how to configure RIP routing protocol on Juniper and Cisco routers.

rjlogs, lab, RIP, cisco, juniper, gns3

R1 is a Cisco router, J1 and J2 are Juniper routers.

Let’s starting from J1 :

Assign IP address to each interfaces: IP 172.28.1.3/24 on interface  ge-0/0/0 that connected to R1, 172.28.2.3/24 on interface ge-0/0/1, and 1.1.1.1/32 for IP loopback interface.

[edit]
root@J1# set interfaces ge-0/0/0 unit 0 family inet address 172.28.1.3/24

[edit]
root@J1# set interfaces ge-0/0/1 unit 0 family inet address 172.28.2.3/24

[edit]
root@J1# set interfaces lo0 unit 0 family inet address 1.1.1.1/32

Now tell the router what interfaces will participate in RIP, and we have to give the process an identifier, here we call it RIP-LAB.

[edit]
root@J1# edit protocols rip

[edit protocols rip]
root@J1# set group RIP-LAB neighbor ge-0/0/0.0

[edit protocols rip]
root@J1# set group RIP-LAB neighbor ge-0/0/1.0

Continue reading “Configure RIP on Juniper and Cisco Routers”