Configuring an EtherChannel Link

etherchannel

Here’s an example of EtherChannel configuration.

SW1 SW2
Port fa0/21 to port fa0/21 SW2 Port fa0/21 to port fa0/21 SW1
Port fa0/22 to port fa0/22 SW2 Port fa0/22 to port fa0/22 SW1
Port fa0/23 to port fa0/23 SW2 Port fa0/23 to port fa0/23 SW1
Port fa0/24 to port fa0/24 SW2 Port fa0/24 to port fa0/24 SW1
Port fa0/1 to PC1 Port fa0/1 to PC3
Port fa0/2 to PC2 Port fa0/2 to PC4

PC1 : 10.10.10.1/24 – VLAN 10
PC2 : 10.10.20.1/24 – VLAN 20
PC3 : 10.10.10.2/24 – VLAN 10
PC4 : 10.10.20.2/24 – VLAN 20

Configuring SW1 :

SW1#conf t
SW1(config)#vlan 10
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#exit
SW1(config)#interface f0/1
SW1(config-if)#description to PC1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10

SW1(config)#interface f0/2
SW1(config-if)#description to PC2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20

SW1(config)#interface range f0/21 – f0/24
SW1(config-if-range)#no shut
SW1(config-if-range)#channel-group 1 mode active

SW1(config)#interface port-channel 1
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan 10,20

Configuring SW2 :

SW2(config)#vlan 10
SW2(config-vlan)#exit
SW2(config)#vlan 20
SW2(config-vlan)#exit
SW2(config)#inter
SW2(config)#interface f0/1
SW1(config-if)#description to PC3
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10

SW2(config)#interface f0/2
SW1(config-if)#description to PC4
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 20

SW2(config)#interface range f0/21 – f0/24
SW2(config-if-range)#no shut
SW2(config-if-range)#channel-group 1 mode active

SW2(config)#interface port-channel 1
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk allowed vlan 10,20

Now verify on SW1 and SW2 that all four interfaces are participating in Etherchannel :

etherchannel, portchannel, cisco, lab

etherchannel, portchannel, cisco, lab

Now verify connection from PC1 to PC3 and PC2 to PC4, all should be OK.

Ping PC1 to PC3 :
testing-pc1-to-pc3

Ping PC2 to PC4 :
testing-pc2-to-pc4

For additional testing, we can shutdown 3 interfaces, so the connection will be use 1 interface. Shutdown interface f0/21, f0/22, and f0/23 on SW1.

SW1(config)#interface range f0/21 – f0/23

SW1(config-if-range)#shutdown

SW1(config-if-range)#

%LINK-5-CHANGED: Interface FastEthernet0/21, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/21, changed state to down

%LINK-5-CHANGED: Interface FastEthernet0/22, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/22, changed state to down

%LINK-5-CHANGED: Interface FastEthernet0/23, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down

SW1(config-if-range)#

Now test connection again from PC1 to PC3 and PC2 to PC 4 , ping results should be OK.

Ping PC1 to PC3 after shutdown 3 interfaces :
testing-pc1-to-pc3

Ping PC2 to PC4 after shutdown 3 interfaces :
testing-pc2-to-pc4

 

Also read : EtherChannel – Port Link Aggregation.

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s